What is CAR ? Please refer to QoS | CAR, CIR, MIR, EIR, PIR, CDR for glossary.
CAR is used to limit traffic that can enter or exit an interface.
CAR is part of Classification on QoS implementation.
How to set CAR and apply?
#### Set CAR rate policies for 1 Mbps or 1024 Kbps
rate-limit input 1024000 128000 128000 conform-action transmit exceed-action drop
rate-limit output 1024000 128000 128000 conform-action transmit exceed-action drop
#### Set CAR rate policies for 4 Mbps or 4096 Kbps
rate-limit input 4096000 512000 512000 conform-action transmit exceed-action drop
rate-limit output 4096000 512000 512000 conform-action transmit exceed-action drop
So what is 128000 or 512000 in rate policies above?
1. input/output is direction traffic incoming or outgoing
2. 1024000/4096000 is rate traffic in bits per seconds
3. first 128000/512000 is normal burst in bytes, large traffic burst for normal condition
4. second 128000/512000 is maximum burst in bytes, exceed burst between normal and maximum is possible
5. transmit is traffic that falls under rate (2) will always conform
6. drop is traffic that over rate (2) will drop
After set CAR rate policies, what next?
#### Apply CAR to interface
IOS(config-if)#
interface FastEthernet1/0
description To-Router
ip address 192.168.100.1 255.255.255.0
rate-limit input 1024000 128000 128000 conform-action transmit exceed-action drop
rate-limit output 1024000 128000 128000 conform-action transmit exceed-action drop
#### Verify CAR
IOS#show interfaces FastEthernet1/0 rate-limit
FastEthernet1/0 To-Router
Input
matches: all traffic
params: 1024000 bps, 128000 limit, 128000 extended limit
conformed 3 packets, 282 bytes; action: transmit
exceeded 0 packets, 0 bytes; action: drop
last packet: 2352ms ago, current burst: 0 bytes
last cleared 00:00:23 ago, conformed 0 bps, exceeded 0 bps
Output
matches: all traffic
params: 1024000 bps, 128000 limit, 128000 extended limit
conformed 3 packets, 282 bytes; action: transmit
exceeded 0 packets, 0 bytes; action: drop
last packet: 2156ms ago, current burst: 0 bytes
last cleared 00:00:23 ago, conformed 0 bps, exceeded 0 bps
Wednesday, July 31, 2013
Tuesday, July 30, 2013
Juniper Rollback Configuration
JunOS from Juniper Operating System has best management config, due to internal archive config feature. By default JunOS will save 49 archive config, it's very usefull to always save config whenever you modify. The trigger is 'commit' or when execute and save config. The feature is same with Cisco archive config but need to enable first before use.
For rollback, you can rollback anytime, please find demo capture.
user@My_Juniper> configure
Entering configuration mode
[edit]
user@My_Juniper# set system host-name Juniper
[edit]
user@My_Juniper# show | compare
[edit system]
- host-name My_Juniper;
+ host-name Juniper;
[edit]
user@My_Juniper# commit check
configuration check succeeds
[edit]
user@My_Juniper# commit
commit complete
[edit]
user@Juniper# rollback ?
Possible completions:
<[Enter]> Execute this command
0 2013-07-30 06:41:27 UTC by user via cli
1 2013-07-30 05:19:50 UTC by user via cli
2
3
4
5
6
7
8
9
10
11
..
..
..
48
49
| Pipe through a command
[edit]
user@Juniper# show | compare rollback 1
[edit system]
- host-name My_Juniper;
+ host-name Juniper;
[edit]
user@Juniper# rollback 1
load complete
[edit]
user@Juniper# show | compare
[edit system]
- host-name Juniper;
+ host-name My_Juniper;
[edit]
user@Juniper# commit check
configuration check succeeds
[edit]
user@Juniper# commit
commit complete
[edit]
user@My_Juniper# exit
Exiting configuration mode
user@My_Juniper>
How about external backup configuration, JunOS also has internal function for backup configuration use several protocol ftp, http or scp.
Hope it's usefull for you, enjoy reading.
For rollback, you can rollback anytime, please find demo capture.
user@My_Juniper> configure
Entering configuration mode
[edit]
user@My_Juniper# set system host-name Juniper
[edit]
user@My_Juniper# show | compare
[edit system]
- host-name My_Juniper;
+ host-name Juniper;
[edit]
user@My_Juniper# commit check
configuration check succeeds
[edit]
user@My_Juniper# commit
commit complete
[edit]
user@Juniper# rollback ?
Possible completions:
<[Enter]> Execute this command
0 2013-07-30 06:41:27 UTC by user via cli
1 2013-07-30 05:19:50 UTC by user via cli
2
3
4
5
6
7
8
9
10
11
..
..
..
48
49
| Pipe through a command
[edit]
user@Juniper# show | compare rollback 1
[edit system]
- host-name My_Juniper;
+ host-name Juniper;
[edit]
user@Juniper# rollback 1
load complete
[edit]
user@Juniper# show | compare
[edit system]
- host-name Juniper;
+ host-name My_Juniper;
[edit]
user@Juniper# commit check
configuration check succeeds
[edit]
user@Juniper# commit
commit complete
[edit]
user@My_Juniper# exit
Exiting configuration mode
user@My_Juniper>
How about external backup configuration, JunOS also has internal function for backup configuration use several protocol ftp, http or scp.
Hope it's usefull for you, enjoy reading.
Monday, July 29, 2013
LTE, EPS Series include EPC & E-UTRAN
Please enjoy, several posting about Evolved Packet System, Evolved Packet Core and Cisco, Juniper simple implementation.
0. The EPS Glossary of Terms and Acronyms
1. Packet Switching Overview
2. Packet Core (EPC) inside of the EPS
3. LTE Interface name and Virtual Routing
4. LTE Traffic Flow inside IP Backbone
5. EPS Bearer Flow and description
6. Implementation Cisco L3 Switch for EPS (S1 for E-UTRAN, S11, S5, S6a and SGi)
7. Implementation Juniper L3 Switch for EPS (S1 for E-UTRAN, S11, S5, S6a and SGi)
For next posting about LTE, EPS will be described more advanced.
Thank you for reading, correct me if I wrong and comment are welcome :-)
0. The EPS Glossary of Terms and Acronyms
1. Packet Switching Overview
2. Packet Core (EPC) inside of the EPS
3. LTE Interface name and Virtual Routing
4. LTE Traffic Flow inside IP Backbone
5. EPS Bearer Flow and description
6. Implementation Cisco L3 Switch for EPS (S1 for E-UTRAN, S11, S5, S6a and SGi)
7. Implementation Juniper L3 Switch for EPS (S1 for E-UTRAN, S11, S5, S6a and SGi)
For next posting about LTE, EPS will be described more advanced.
Thank you for reading, correct me if I wrong and comment are welcome :-)
Sunday, July 28, 2013
Cisco Rollback Configuration
Hi weekender's (guys is enjoy weekend), I just complete previous posting.
It's very easy to rollback Cisco IOS software configuration. But you must enable archive feature first before can use rollback feature. Please find Cisco Archive Config to enable. To rollback configuration from archive copy archive config to running-config.
IOS#conf t
Enter configuration commands, one per line. End with CNTL/Z.
IOS(config)#hostname IOOS
IOOS(config)#exit
IOOS#show archive config differences disk0:/-1
Contextual Config Diffs:
+hostname IOS
-hostname IOOS
IOOS#copy disk0:/-1 running-config
Destination filename [running-config]?
2248 bytes copied in 0.680 secs (3306 bytes/sec)
IOS#
It's very easy to rollback Cisco IOS software configuration. But you must enable archive feature first before can use rollback feature. Please find Cisco Archive Config to enable. To rollback configuration from archive copy archive config to running-config.
IOS#conf t
Enter configuration commands, one per line. End with CNTL/Z.
IOS(config)#hostname IOOS
IOOS(config)#exit
IOOS#show archive config differences disk0:/-1
Contextual Config Diffs:
+hostname IOS
-hostname IOOS
IOOS#copy disk0:/-1 running-config
Destination filename [running-config]?
2248 bytes copied in 0.680 secs (3306 bytes/sec)
IOS#
Friday, July 26, 2013
The EPS Bearer Flow
Please find the picture of EPS Bearer flow as complement previous posting about LTE EPS Bearer Flow.
Thursday, July 25, 2013
Cisco Archive Config (Automatic Backup Config)
Cisco IOS Software by default doesn't enable archive config feature. What is for this feature ? It's very usefull to always save config whenever you modify. I can say it's automatic backup config when modify happen. What is trigger configuration is change in IOS software ? Saving (write memory). Every time 'write memory' is execute, IOS will be copy configuration from running-config to startup-config. We use that trigger to backup configuration to another file every time 'write memory' is execute.
# Enable archive #
IOS#show archive
Archive feature not enabled
IOS(config)#
archive
path disk0:/
write-memory
IOS#show archive
There are currently 1 archive configurations saved.
The next archive file will be named disk0:/-1
Archive # Name
0
1
2
3
4
5
6
7
8
9
10
11
12
13
14
# Make manual archive or backup running-config #
IOS#archive config
IOS#show archive
There are currently 2 archive configurations saved.
The next archive file will be named disk0:/-2
Archive # Name
0
1 disk0:/-1 <- font="" most="" recent="">->
2
3
4
5
6
7
8
9
10
11
12
13
14
# Automatic make archive (backup) when write memory #
IOS#write memory
Building configuration...
[OK]
IOS#show archive
There are currently 3 archive configurations saved.
The next archive file will be named disk0:/-3
Archive # Name
0
1 disk0:/-1
2 disk0:/-2 <- font="" most="" recent="">->
3
4
5
6
7
8
9
10
11
12
13
14
Why are we need to archive config ?
We can rollback configuration from archive anytime, copy archive config to running-config even archive config save 14 configuration.
Have fun, I hope it usefull.
# Enable archive #
IOS#show archive
Archive feature not enabled
IOS(config)#
archive
path disk0:/
write-memory
IOS#show archive
There are currently 1 archive configurations saved.
The next archive file will be named disk0:/-1
Archive # Name
0
1
2
3
4
5
6
7
8
9
10
11
12
13
14
# Make manual archive or backup running-config #
IOS#archive config
IOS#show archive
There are currently 2 archive configurations saved.
The next archive file will be named disk0:/-2
Archive # Name
0
1 disk0:/-1 <- font="" most="" recent="">->
2
3
4
5
6
7
8
9
10
11
12
13
14
# Automatic make archive (backup) when write memory #
IOS#write memory
Building configuration...
[OK]
IOS#show archive
There are currently 3 archive configurations saved.
The next archive file will be named disk0:/-3
Archive # Name
0
1 disk0:/-1
2 disk0:/-2 <- font="" most="" recent="">->
3
4
5
6
7
8
9
10
11
12
13
14
Why are we need to archive config ?
We can rollback configuration from archive anytime, copy archive config to running-config even archive config save 14 configuration.
Have fun, I hope it usefull.
LTE - EPS Bearer Flow
The simple definition of EPS Bearer is process UE to get IP address (this is definition by me). What actually happen inside EPS bearer?
# The EPS Bearer #
UE ---- eNodeB
->1. Attach request
->Wireless interface
eNodeB ---- MME
->2. Attach request
->S1-MME interface (SCTP)
MME ---- SGW
->3. Create session request
->S11 interface (GTPv2-C)
SGW ---- PGW
->4. Create session request
->S5 interface (GTPv2-C)
PGW ---- SGW
->5. Create session response
->S5 interface (GTPv2-C)
SGW ---- MME
->6. Create session response
->S11 interface (GTPv2-C)
MME ---- eNodeB
->7. Attach accept
->S1-MME interface (SCTP)
eNodeB ---- UE
->8. Attach accept
->Wireless interface
Wednesday, July 24, 2013
LTE Traffic Flow inside IP Backbone
I have explained about EPS in several posted include each LTE interface for simple architecture. Example implement Cisco & Juniper L3 Switch for EPC and E-UTRAN, we can called that is IP Backbone (IPBB). The LTE traffic flow inside IP Backbone is simple. It can ping between node in virtual routing, example S11_VR virtual routing: MME can ping to SGW and vice versa. The previous example is very simple, only one node each, that is not reflect the live network, may be implemented for very simple lab. For expand network you can enable OSPF or MPLS inside IPBB as you need.
Before UE can access internet or VPN use LTE, there are some step will be happen. The simple step for traffic flow, I will divide it become 2, the EPS bearer and the access internet. The EPS bearer is reflect to control plane process and the access internet is user plane process (payload).
The simple definition of EPS Bearer is process UE to get signal and IP address. The access internet is generic process IP flow use TCP or UDP. Each interface between two node use different protocol. If you dump traffic between them you will see encapsulation/tunneling based on below description.
For example:
S11 interface use GTPv2-C protocol to transfer between MME and SGW. The GTPv2-C isn't native encapsulation based on OSI layer but tunneling in layer 4. Layer 3 is general IP flow and layer 2 is ethernet. Basicly GTP packet based on UDP for transfer. But GTP-C and GTP-U has different port for transfer, GTP-C use UDP 2123 and GTP-U use UDP 2152.
# The EPS Bearer #
UE ---- eNodeB
->Wireless interface
eNodeB ---- MME
->S1-MME interface (SCTP)
MME ---- HSS
->S6a interface (Diameter)
MME ---- SGW
->S11 interface (GTPv2-C)
SGW ---- PGW
->S5 interface (GTPv2-C)
# The Access Internet #
UE ==== eNodeB
=>Wireless interface
eNodeB ==== SGW
=>S1-U interface (GTPv1-U)
SGW ==== PGW
=>S5 interface (GTPv2-U)
PGW ==== Gateway to Internet/VPN/etc.
=>SGi interface (IP)
Before UE can access internet or VPN use LTE, there are some step will be happen. The simple step for traffic flow, I will divide it become 2, the EPS bearer and the access internet. The EPS bearer is reflect to control plane process and the access internet is user plane process (payload).
The simple definition of EPS Bearer is process UE to get signal and IP address. The access internet is generic process IP flow use TCP or UDP. Each interface between two node use different protocol. If you dump traffic between them you will see encapsulation/tunneling based on below description.
For example:
S11 interface use GTPv2-C protocol to transfer between MME and SGW. The GTPv2-C isn't native encapsulation based on OSI layer but tunneling in layer 4. Layer 3 is general IP flow and layer 2 is ethernet. Basicly GTP packet based on UDP for transfer. But GTP-C and GTP-U has different port for transfer, GTP-C use UDP 2123 and GTP-U use UDP 2152.
# The EPS Bearer #
UE ---- eNodeB
->Wireless interface
eNodeB ---- MME
->S1-MME interface (SCTP)
MME ---- HSS
->S6a interface (Diameter)
MME ---- SGW
->S11 interface (GTPv2-C)
SGW ---- PGW
->S5 interface (GTPv2-C)
# The Access Internet #
UE ==== eNodeB
=>Wireless interface
eNodeB ==== SGW
=>S1-U interface (GTPv1-U)
SGW ==== PGW
=>S5 interface (GTPv2-U)
PGW ==== Gateway to Internet/VPN/etc.
=>SGi interface (IP)
Tuesday, July 23, 2013
Implement Juniper L3 Switch for EPS E-UTRAN (S1-MME,S1-U Interface)
Another example config on Juniper layer 3 switch (L3_Switch) for implement E-UTRAN network (S1-MME, S1-U interface).
Please refer to LTE Interface and Virtual Routing for picture. Config for S11 and SGi, S5, S6a Interface.
#### Parameter (S11, SGi, S5, S6a, S1-MME, S1-U)
L3_Switch (JunOS)
ge-0/0/1: S11_MME
#### Parameter (S11, SGi, S5, S6a, S1-MME, S1-U)
L3_Switch (JunOS)
ge-0/0/1: S11_MME
ge-0/0/2: S11_SGW
ge-0/0/3: S11_DNS
ge-0/0/4: S6a_HSS
ge-0/0/5: S6a_MME
ge-0/0/6: S5_SGW
ge-0/0/7: S5_PGW
ge-0/0/8: SGi_PGW
ge-0/0/9: S1_MME
ge-0/0/10: S1_ENODEB
ge-0/0/11: S1U_SGW
ge-0/0/12: S1U_ENODEB
IP Address & Routing
MME_S11 192.168.16.2/28, gateway (default route) 192.168.16.1
SGW_S11 192.168.20.2/28, gateway (default route) 192.168.20.1
DNS_S11 192.168.21.2/28, gateway (default route) 192.168.21.1
HSS_S6a 192.168.8.2/28, gateway (default route) 192.168.8.1
MME_S6a 192.168.9.2/28, gateway (default route) 192.168.9.1
SGW_S5 192.168.24.2/28, gateway (default route) 192.168.24.1
PGW_S5 192.168.28.2/28, gateway (default route) 192.168.28.1
PGW_SGi 192.168.32.2/28, gateway (default route) 192.168.32.1
MME_S1 192.168.0.2/28, gateway (default route) 192.168.0.1
ENODEB_S1 192.168.2.2/28, gateway (default route) 192.168.2.1
SGW_S1U 192.168.4.2/28, gateway (default route) 192.168.4.1
ENODEB_S1U 192.168.6.2/28, gateway (default route) 192.168.6.1
#### Config
set interfaces ge-0/0/9 description "S1_MME"
set interfaces ge-0/0/9 ether-options no-auto-negotiation
set interfaces ge-0/0/9 ether-options link-mode full-duplex
set interfaces ge-0/0/9 ether-options speed 100m
set interfaces ge-0/0/9 ether-options speed 100m
set interfaces ge-0/0/9 unit 0 family inet address 192.168.0.1/28
set interfaces ge-0/0/10 description "S1_ENODEB"
set interfaces ge-0/0/10 ether-options no-auto-negotiation
set interfaces ge-0/0/10 ether-options link-mode full-duplex
set interfaces ge-0/0/10 ether-options speed 100m
set interfaces ge-0/0/10 unit 0 family inet address 192.168.2.1/28
set interfaces ge-0/0/11 description "S1U_SGW"
set interfaces ge-0/0/11 ether-options no-auto-negotiation
set interfaces ge-0/0/11 ether-options link-mode full-duplex
set interfaces ge-0/0/11 ether-options speed 100m
set interfaces ge-0/0/11 unit 0 family inet address 192.168.4.1/28
set interfaces ge-0/0/12 description "S1U_ENODEB"
set interfaces ge-0/0/12 ether-options no-auto-negotiation
set interfaces ge-0/0/12 ether-options link-mode full-duplex
set interfaces ge-0/0/12 ether-options speed 100m
set interfaces ge-0/0/12 unit 0 family inet address 192.168.6.1/28
set routing-instances S1_VR instance-type virtual-router
set routing-instances S1_VR interface ge-0/0/9.0
set routing-instances S1_VR interface ge-0/0/10.0
set routing-instances S1_VR interface ge-0/0/11.0
set routing-instances S1_VR interface ge-0/0/12.0
Monday, July 22, 2013
Implement Cisco L3 Switch for EPS E-UTRAN (S1-MME,S1-U Interface)
Here are the last config on Cisco layer 3 switch (L3_Switch) for implement E-UTRAN network (S1-MME, S1-U interface).
Please refer to LTE Interface and Virtual Routing for picture. Config for S11 and SGi, S5, S6a Interface.
#### Parameter (S11, SGi, S5, S6a, S1-MME, S1-U)
L3_Switch (Cisco)
Ethernet0/1: S11_MME
Ethernet0/2: S11_SGW
Ethernet0/3: S11_DNS
Ethernet0/4: S6a_HSS
Ethernet0/5: S6a_MME
Ethernet0/6: S5_SGW
Ethernet0/7: S5_PGW
Ethernet0/8: SGi_PGW
Ethernet0/9: S1_MME
Ethernet0/10: S1_ENODEB
Ethernet0/11: S1U_SGW
Ethernet0/12: S1U_ENODEB
IP Address & Routing
MME_S11 192.168.16.2/28, gateway (default route) 192.168.16.1
SGW_S11 192.168.20.2/28, gateway (default route) 192.168.20.1
DNS_S11 192.168.21.2/28, gateway (default route) 192.168.21.1
HSS_S6a 192.168.8.2/28, gateway (default route) 192.168.8.1
MME_S6a 192.168.9.2/28, gateway (default route) 192.168.9.1
SGW_S5 192.168.24.2/28, gateway (default route) 192.168.24.1
PGW_S5 192.168.28.2/28, gateway (default route) 192.168.28.1
PGW_SGi 192.168.32.2/28, gateway (default route) 192.168.32.1
MME_S1 192.168.0.2/28, gateway (default route) 192.168.0.1
ENODEB_S1 192.168.2.2/28, gateway (default route) 192.168.2.1
SGW_S1U 192.168.4.2/28, gateway (default route) 192.168.4.1
ENODEB_S1U 192.168.6.2/28, gateway (default route) 192.168.6.1
#### Config
L3_Switch#
vlan 19
name S1_MME
state active
no shutdown
interface Ethernet0/9
switchport
switchport access vlan 19
interface vlan19
description S1_MME
ip vrf forwarding S1_VR
ip address 192.168.0.1 255.255.255.240
no shutdown
vlan 20
name S1_ENODEB
state active
no shutdown
interface Ethernet0/10
switchport
switchport access vlan 20
interface vlan20
description S1_ENODEB
ip vrf forwarding S1_VR
ip address 192.168.2.1 255.255.255.240
no shutdown
vlan 21
name S1U_SGW
state active
no shutdown
interface Ethernet0/11
switchport
switchport access vlan 21
interface vlan21
description S1U_SGW
ip vrf forwarding S1_VR
ip address 192.168.4.1 255.255.255.240
no shutdown
vlan 22
name S1U_ENODEB
state active
no shutdown
interface Ethernet0/12
switchport
switchport access vlan 22
interface vlan22
description S1U_ENODEB
ip vrf forwarding S1_VR
ip address 192.168.6.1 255.255.255.240
no shutdown
Correction for IP address in interface L3_Switch, Thank you :-)
Saturday, July 20, 2013
Compare Juniper Config use show | compare
Light posting in weekend about compare. I ever posted about Compare Cisco Config use Diff. Actually I find that feature because I got inspired from JunOS feature.
You can compare configuration with any filename/URL of configuration file or index of rollback configuration file. Usually it's use after modify configuration and want to save or commit.
user@Juniper> configure
Entering configuration mode
[edit]
user@Juniper# set system services ssh
[edit]
user@Juniper# show | compare rollback 0
[edit system services]
+ ssh;
- it's mean compare new config after modify and current configuration (rollback 0)
- + indicates the configuration line exists (different) after modify
or you can use : (the same result)
show | compare only it's mean compare new config after modify and current configuration (rollback 0)
[edit]
user@Juniper# show | compare
[edit system services]
+ ssh;
Easy right! Thank you for reading and have nice weekend :-)
Friday, July 19, 2013
Cisco Enable Secret, Enable Password and Virtual Terminal Password
Would you like to enter the initial configuration dialog?
That dialog will be appear at first time you are start up Cisco device. For advanced user and bettter initial will choose 'no'. Why 'no' ? You can setup by enter configure terminal and copy paste from example configuration, that is easiest way.
Escape character is '^]'.
% Please answer 'yes' or 'no'.
Would you like to enter the initial configuration dialog? [yes/no]: no
Press RETURN to get started!
What happen if will choose 'yes' ? Several dialog will appear and some question have default settings are in square brackets '[]'. If you decide to choose 'yes', some mandatory parameter must be fill. That are enable secret, enable password and virtual terminal password. What are they ?
The enable secret is a password used to protect access to
privileged EXEC and configuration modes. This password, after
entered, becomes encrypted in the configuration.
Enter enable secret:
% No defaulting allowed
Enter enable secret:
% No defaulting allowed
Enter enable secret:
The enable password is used when you do not specify an
enable secret password, with some older software versions, and
some boot images.
Enter enable password:
% No defaulting allowed
Enter enable password:
% No defaulting allowed
Enter enable password:
The virtual terminal password is used to protect
access to the router over a network interface.
Enter virtual terminal password:
% No defaulting allowed
Enter virtual terminal password:
% No defaulting allowed
Enter virtual terminal password:
The last dialog is selection to saving config.
[0] Go to the IOS command prompt without saving this config.
[1] Return back to the setup without saving this config.
[2] Save this configuration to nvram and exit.
Enter your selection [2]: 0
% You can enter the setup, by typing setup at IOS command prompt
Press RETURN to get started!
Have fun with Cisco IOS and have nice weekend.
Implement Juniper L3 Switch for EPC (SGi,S5,S6a Interface)
Another example complete config on Juniper layer 3 switch (L3_Switch) for implement EPC (SGi, S5, S6a interface). Please find parameter for crosscheck. Previous posting is implement Cisco L3 Switch for EPC (SGi,S5,S6a Interface), have posted config on Juniper for S11 Interface.
Please refer to LTE Interface and Virtual Routing for picture.
#### Parameter (S11, SGi, S5, S6a)
L3_Switch (JunOS)
ge-0/0/1: S11_MME
ge-0/0/2: S11_SGW
ge-0/0/3: S11_DNS
ge-0/0/4: S6a_HSS
ge-0/0/5: S6a_MME
ge-0/0/6: S5_SGW
ge-0/0/7: S5_PGW
ge-0/0/8: SGi_PGW
IP Address & Routing
MME_S11 192.168.16.2/28, gateway (default route) 192.168.16.1
SGW_S11 192.168.20.2/28, gateway (default route) 192.168.20.1
DNS_S11 192.168.21.2/28, gateway (default route) 192.168.21.1
HSS_S6a 192.168.8.2/28, gateway (default route) 192.168.8.1
MME_S6a 192.168.9.2/28, gateway (default route) 192.168.9.1
SGW_S5 192.168.24.2/28, gateway (default route) 192.168.24.1
PGW_S5 192.168.28.2/28, gateway (default route) 192.168.28.1
PGW_SGi 192.168.32.2/28, gateway (default route) 192.168.32.1
#### Config
set interfaces ge-0/0/4 description "S6a_HSS"
set interfaces ge-0/0/4 ether-options no-auto-negotiation
set interfaces ge-0/0/4 ether-options link-mode full-duplex
set interfaces ge-0/0/4 ether-options speed 100m
set interfaces ge-0/0/4 unit 0 family inet address 192.168.8.1/28
set interfaces ge-0/0/5 description "S6a_MME"
set interfaces ge-0/0/5 ether-options no-auto-negotiation
set interfaces ge-0/0/5 ether-options link-mode full-duplex
set interfaces ge-0/0/5 ether-options speed 100m
set interfaces ge-0/0/5 unit 0 family inet address 192.168.9.1/28
set interfaces ge-0/0/6 description "SGW_S5"
set interfaces ge-0/0/6 ether-options no-auto-negotiation
set interfaces ge-0/0/6 ether-options link-mode full-duplex
set interfaces ge-0/0/6 ether-options speed 100m
set interfaces ge-0/0/6 unit 0 family inet address 192.168.24.1/28
set interfaces ge-0/0/7 description "PGW_S5"
set interfaces ge-0/0/7 ether-options no-auto-negotiation
set interfaces ge-0/0/7 ether-options link-mode full-duplex
set interfaces ge-0/0/7 ether-options speed 100m
set interfaces ge-0/0/7 unit 0 family inet address 192.168.28.1/28
set interfaces ge-0/0/8 description "PGW_SGi"
set interfaces ge-0/0/8 ether-options no-auto-negotiation
set interfaces ge-0/0/8 ether-options link-mode full-duplex
set interfaces ge-0/0/8 ether-options speed 100m
set interfaces ge-0/0/8 unit 0 family inet address 192.168.32.1/28
set routing-instances S5_VR instance-type virtual-router
set routing-instances S5_VR interface ge-0/0/6.0
set routing-instances S5_VR interface ge-0/0/7.0
set routing-instances S6a_VR instance-type virtual-router
set routing-instances S6a_VR interface ge-0/0/4.0
set routing-instances S6a_VR interface ge-0/0/5.0
set routing-instances SGi_VR instance-type virtual-router
set routing-instances SGi_VR interface ge-0/0/8.0
Thursday, July 18, 2013
Implement Cisco L3 Switch for EPC (SGi,S5,S6a Interface)
Here are complete config on Cisco layer 3 switch (L3_Switch) in Core Network (EPC) for implement SGi,S5,S6a Interface. I have posted config for Implement S11 Interface.
#### Parameter (S11, SGi, S5, S6a)
L3_Switch (Cisco)
Ethernet0/1: S11_MME
Ethernet0/2: S11_SGW
Ethernet0/3: S11_DNS
Ethernet0/4: S6a_HSS
Ethernet0/5: S6a_MME
Ethernet0/6: S5_SGW
Ethernet0/7: S5_PGW
Ethernet0/8: SGi_PGW
IP Address & Routing
MME_S11 192.168.16.2/28, gateway (default route) 192.168.16.1
SGW_S11 192.168.20.2/28, gateway (default route) 192.168.20.1
DNS_S11 192.168.21.2/28, gateway (default route) 192.168.21.1
HSS_S6a 192.168.8.2/28, gateway (default route) 192.168.8.1
MME_S6a 192.168.9.2/28, gateway (default route) 192.168.9.1
SGW_S5 192.168.24.2/28, gateway (default route) 192.168.24.1
PGW_S5 192.168.28.2/28, gateway (default route) 192.168.28.1
PGW_SGi 192.168.32.2/28, gateway (default route) 192.168.32.1
#### Config
L3_Switch#
ip vrf S6a_VR
rd 65000:8
ip vrf S5_VR
rd 65000:24
ip vrf SGi_VR
rd 65000:32
ip vrf S6a_VR
rd 65000:8
ip vrf S5_VR
rd 65000:24
ip vrf SGi_VR
rd 65000:32
vlan 14
name S6a_HSS
state active
no shutdown
interface Ethernet0/4
switchport
switchport access vlan 14
interface vlan14
description S6a_HSS
ip vrf forwarding S6a_VR
ip address 192.168.8.1 255.255.255.240
no shutdown
vlan 15
name S6a_MME
state active
no shutdown
interface Ethernet0/5
switchport
switchport access vlan 15
interface vlan15
description S6a_MME
ip vrf forwarding S6a_VR
ip address 192.168.9.1 255.255.255.240
no shutdown
vlan 16
name S5_SGW
state active
no shutdown
interface Ethernet0/6
switchport
switchport access vlan 16
interface vlan16
description S5_SGW
ip vrf forwarding S5_VR
ip address 192.168.24.1 255.255.255.240
no shutdown
vlan 17
name S5_PGW
state active
no shutdown
interface Ethernet0/7
switchport
switchport access vlan 17
interface vlan17
description S5_PGW
ip vrf forwarding S5_VR
ip address 192.168.28.1 255.255.255.240
no shutdown
vlan 18
name SGi_PGW
state active
no shutdown
interface Ethernet0/8
switchport
switchport access vlan 18
interface vlan18
description SGi_PGW
ip vrf forwarding SGi_VR
ip address 192.168.32.1 255.255.255.240
no shutdown
name S6a_HSS
state active
no shutdown
interface Ethernet0/4
switchport
switchport access vlan 14
interface vlan14
description S6a_HSS
ip vrf forwarding S6a_VR
ip address 192.168.8.1 255.255.255.240
no shutdown
vlan 15
name S6a_MME
state active
no shutdown
interface Ethernet0/5
switchport
switchport access vlan 15
interface vlan15
description S6a_MME
ip vrf forwarding S6a_VR
ip address 192.168.9.1 255.255.255.240
no shutdown
vlan 16
name S5_SGW
state active
no shutdown
interface Ethernet0/6
switchport
switchport access vlan 16
interface vlan16
description S5_SGW
ip vrf forwarding S5_VR
ip address 192.168.24.1 255.255.255.240
no shutdown
vlan 17
name S5_PGW
state active
no shutdown
interface Ethernet0/7
switchport
switchport access vlan 17
interface vlan17
description S5_PGW
ip vrf forwarding S5_VR
ip address 192.168.28.1 255.255.255.240
no shutdown
vlan 18
name SGi_PGW
state active
no shutdown
interface Ethernet0/8
switchport
switchport access vlan 18
interface vlan18
description SGi_PGW
ip vrf forwarding SGi_VR
ip address 192.168.32.1 255.255.255.240
no shutdown
Revise Configuration Cisco L3 Switch for S11 Interface
Some of Cisco switch with layer 3 feature (Cisco 3750, etc) or routers with switching capabilities (Cisco 76 series, etc) have different way to config. In previous post Implement Cisco L3 Switch for S11 Interface and Implement Cisco L3 Switch for MME,SGW,DNS (S11 Interface), used physical-interface to configure IP address and virtual routing (VRF). Also don't forget to configure 'no switchport' to enable physical-interface as layer 3, due to some case interface as layer 2 by default.
#### Config
L3_Switch#
ip vrf S11_VR
rd 65000:16
interface Ethernet0/1
description S11_MME
ip vrf forwarding S11_VR
ip address 192.168.16.1 255.255.255.240
duplex auto
interface Ethernet0/2
description S11_SGW
ip vrf forwarding S11_VR
ip address 192.168.20.1 255.255.255.240
duplex auto
interface Ethernet0/3
description S11_DNS
ip vrf forwarding S11_VR
ip address 192.168.21.1 255.255.255.240
duplex auto
The other way is used vlan-interface to configure IP address and virtual routing (VRF), create vlan-id and assign physical interface to access mode. Also don't forget to configure 'no switchport' to enable vlan-interface as layer 3, due to some case interface as layer 2 by default.
#### Config
L3_Switch#
ip vrf S11_VR
rd 65000:16
vlan 11
name S11_MME
state active
no shutdown
interface Ethernet0/1
switchport
switchport access vlan 11
duplex auto
interface vlan11
description S11_MME
ip vrf forwarding S11_VR
ip address 192.168.16.1 255.255.255.240
vlan 12
name S11_SGW
state active
no shutdown
interface Ethernet0/2
switchport
switchport access vlan 12
duplex auto
interface vlan12
description S11_SGW
ip vrf forwarding S11_VR
ip address 192.168.20.1 255.255.255.240
vlan 13
name S11_DNS
state active
no shutdown
interface Ethernet0/3
switchport
switchport access vlan 13
duplex auto
interface vlan13
description S11_DNS
ip vrf forwarding S11_VR
ip address 192.168.21.1 255.255.255.240
My apologies about it, for next I will use vlan-interface to configure Cisco switch interface as layer 3.
Subscribe to:
Posts (Atom)