Some of Cisco switch with layer 3 feature (Cisco 3750, etc) or routers with switching capabilities (Cisco 76 series, etc) have different way to config. In previous post Implement Cisco L3 Switch for S11 Interface and Implement Cisco L3 Switch for MME,SGW,DNS (S11 Interface), used physical-interface to configure IP address and virtual routing (VRF). Also don't forget to configure 'no switchport' to enable physical-interface as layer 3, due to some case interface as layer 2 by default.
#### Config
L3_Switch#
ip vrf S11_VR
rd 65000:16
interface Ethernet0/1
description S11_MME
ip vrf forwarding S11_VR
ip address 192.168.16.1 255.255.255.240
duplex auto
interface Ethernet0/2
description S11_SGW
ip vrf forwarding S11_VR
ip address 192.168.20.1 255.255.255.240
duplex auto
interface Ethernet0/3
description S11_DNS
ip vrf forwarding S11_VR
ip address 192.168.21.1 255.255.255.240
duplex auto
The other way is used vlan-interface to configure IP address and virtual routing (VRF), create vlan-id and assign physical interface to access mode. Also don't forget to configure 'no switchport' to enable vlan-interface as layer 3, due to some case interface as layer 2 by default.
#### Config
L3_Switch#
ip vrf S11_VR
rd 65000:16
vlan 11
name S11_MME
state active
no shutdown
interface Ethernet0/1
switchport
switchport access vlan 11
duplex auto
interface vlan11
description S11_MME
ip vrf forwarding S11_VR
ip address 192.168.16.1 255.255.255.240
vlan 12
name S11_SGW
state active
no shutdown
interface Ethernet0/2
switchport
switchport access vlan 12
duplex auto
interface vlan12
description S11_SGW
ip vrf forwarding S11_VR
ip address 192.168.20.1 255.255.255.240
vlan 13
name S11_DNS
state active
no shutdown
interface Ethernet0/3
switchport
switchport access vlan 13
duplex auto
interface vlan13
description S11_DNS
ip vrf forwarding S11_VR
ip address 192.168.21.1 255.255.255.240
My apologies about it, for next I will use vlan-interface to configure Cisco switch interface as layer 3.
No comments:
Post a Comment