Friday, October 5, 2007

Load Balancing with eBGP Multihop

Now here I show about Load Balancing 2 or more link with BGP. BGP need to configure is use eBGP multihop keyword.

What is eBGP multihop use ?
>> eBGP multihop use establish 2 BGP peer not direct connected that mean TTL value is more than 1, we can use scenario I-BGP (same AS number) or E-BGP (different AS number) to use eBGP multihop.

How between BGP peer not direct connected can communicate use TCP 179 ?
>> we need IGP to carry TCP 179 between BGP peer.

Let's look at this example.
This scenario :
o R1 & R2 establish BGP peer with different AS number
o BGP peer use loopback interface
o use static route to communicate with BGP neighbor
o between R1 & R2 use 2 link serial interface so to communicate with BGP neighbor can load balancing use these link

R1#
interface Serial1/1
ip address 10.1.1.1 255.255.255.252
end

interface Serial1/2
ip address 10.1.2.1 255.255.255.252
end

interface Loopback0
ip address 1.1.1.1 255.255.255.255
end

ip route 2.2.2.2 255.255.255.255 10.1.1.2
ip route 2.2.2.2 255.255.255.255 10.1.2.2

router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 2
neighbor 2.2.2.2 ebgp-multihop 3
neighbor 2.2.2.2 update-source Loopback0
no auto-summary

R2#
interface Serial1/1
ip address 10.1.1.2 255.255.255.252
end

interface Serial1/2
ip address 10.1.2.2 255.255.255.252
end

interface Loopback0
ip address 2.2.2.2 255.255.255.255
end

ip route 1.1.1.1 255.255.255.255 10.1.1.1
ip route 1.1.1.1 255.255.255.255 10.1.2.1

router bgp 2
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 ebgp-multihop 3
neighbor 1.1.1.1 update-source Loopback0
no auto-summary

R1#sh ip ro 2.2.2.2
Routing entry for 2.2.2.2/32
Known via "static", distance 1, metric 0
Routing Descriptor Blocks:
* 10.1.1.2
Route metric is 0, traffic share count is 1
10.1.2.2
Route metric is 0, traffic share count is 1

R1#sh ip bgp sum
BGP router identifier 1.1.1.1, local AS number 1
BGP table version is 1, main routing table version 1

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
2.2.2.2 4 2 7 7 1 0 0 00:03:37 0

Monday, October 1, 2007

EtherChannel to Increase Link Capacity

Here example configure to increase link capacity use Ethernet interface is EtherChannel. Every ethernet interface configure use 'channe-group'.

SW1
interface FastEthernet0/1  
channel-group 1 mode on
!
interface FastEthernet0/2
channel-group 1 mode on
!
interface FastEthernet0/3
channel-group 1 mode on
!
interface Port-channel1
switchport mode dynamic desirable

SW2
interface FastEthernet0/1  
channel-group 1 mode on
!
interface FastEthernet0/2
channel-group 1 mode on
!
interface FastEthernet0/3
channel-group 1 mode on
!
interface Port-channel1
switchport mode dynamic desirable